Updating bios 790 ultra motherboard

Below you will find drivers for all of EVGA's current products.

Simply choose from the selections below and click download for whatever version file you want.

","create one":"Create One","caps search":"Search","caps enter your imei or sn":"Enter your IMEI (for cell phones) or Serial Number (for all other products) below.","tablet":"Tablets","capssn search":"Enter Serial Number","no products found":"Sorry, no products were found that match that query.

For a global site wide search versus a product specific search please use the search bar at the top of the page instead","detect summary":"This secure scan allows us to easily identify your device","add to my products failed":"Add to my products failed","unsure my product":"Unsure what product you have?

updating bios 790 ultra motherboard-43updating bios 790 ultra motherboard-67

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

I booted Free DOS from Ultimate Boot CD and tried it anyway, but the updater just hangs the system with no output (I left it there for 20 minutes just to be sure it wasn't doing a slow silent update). (I am used to Windows-based flashers with my older mobo's which also allow you to save the old BIOS to a backup first, and were very simple to use). PPS: I tried the M-Flash menu in BIOS; it let me backup the current BIOS to a flash drive, saving it as M7576AMS.140.

Anyone else encountered this with updating an MSI board? But when I put the downloaded 4.0 image on the same drive, with the same filename format (M7576AMS.400), the M-Flash option to update the BIOS does not seem to see the Version 4 file. Imagine my complete surprise when I was rewarded with the expected BIOS checksum failure and was subsequently presented with the full BIOS config menu intact, was able to reconfigure everything and finally boot into Windows normally with a functioning system.

After the updated to 4.4, I'm able to use 4GB RAMs.

So thanks again for the help and hopefully some other people find this article and can solve their own problems with it.

Leave a Reply